Ps5 multiplayer does not work

Playstation 5 doesn’t work for multiplayer. It says lost connection to the party host immediately after trying to start the game online. I’ve tried to contact someone but nothing

Try Multiplayer/Split-Screen guide for PS5

Yes obviously I’ve tried that. The game is just broken and doesn’t allow you to play with friends. I am not the only one with this issue

2 Likes

I tried today. I can Join the Lobby of my friend and He can also Join mine. When we try to start a Game we get kickt out.

1 Like

Same as the guy above. We can join each others lobbies but after five or so seconds the one who got invited winds up getting kicked out. Whoever tries joining never even sees a lobby screen. We’re both on Ps5’s. A quick cruise on the goat sim reddit and twitter page and there’s several of us with the same issue.

The most common reason for this is that you/your friends have not enabled port forwarding on your router for the PS5.

Also make sure that all the players have the latest version of the game.

We tried, it doestn work

Don’t you understand that doesn’t work??? Everyone is having this issue and you are not addressing the issue. It’s your mistake and you need to fix it. I will be getting a refund of this game because of the terrible effort of not fixing this issue.

The devs are aware, and if it’s an issue on their end it’ll be fixed. While I partially understand your frustration, passive aggressive comments like yours lead nowhere nor do they have a place on this forum.

2 Likes