No progress in multiplayer

When playing an online multiplayer game on PC, only the host is given any and all progress on instincts/quests/whatever you have.

At first, everything worked, but after few minutes, as the non-host, I just don’t get credit for anything. E.g. the game tells me to get shrunk. I went though the shrinky-thingy a dozen times at least, and nothing. Still asks me to get shrunk.

Anyone faced such an issue?

When doing online play, each player must unlock each item or trinket themselves, that is not a bug, but instinct should work, that is weird. Has this happened multiple times when attempting online play?

We tried to restart the game/reconnect multiple times. Still the same. Only the host gets progress towards anything.

Uninstall then reinstall (if this only happens with one host as far as you are aware then they should do the same) and if that doesn’t work then contact Coffee Stain North via their Twitter, hope this helps.

Edit: don’t submit a support form, that’s for the original Goat Simulator