GS3 is unplayable on high end PC

The first few times I played I could record on OBS and stream on Streamlabs and play the game at max performances without any issues… a few days later the game just suddenly started lagging. At first it was keyboard lags, then sound started freaking out, and now the game just lags like hell and freeze, sometimes freezing all the apps on the computer. I tried so many things that I might forget some but here’s what didn’t fix it.

  • Removing my progress
  • Creating a completely new world and removing all the other saves
  • Deactivating Cloud Save
  • Disconnecting from Epic Games
  • Dropping everything to lowest setting
  • Disconnecting my second monitor
  • Making GS3 the only app running on the computer
  • Reinstalling the game twice
  • Updating drivers and the whole system
  • Trying Windowed and Fullscreen
  • Messed with every game settings

And for the specs:

  • 12th gen i7-12700K
  • 32GB or RAM
  • GTX 3060
  • It’s on an SSD
  • Monitor is set at 1920x1080 @ 60
  • Running on Windows 11
  • I’m playing on Single Player but for cloud save and stuff the connection is 940mbps download 50mbps upload

I’m at a complete loss, I don’t know what else I could try… A freshly restarted computer, reinstalled game and starting from scratch without cloud save on lowest settings with a single 1920x1080@60fps monitor and nothing else running other than services, yet the whole game lags (sound and image) like I was playing on a goddamn potato… Help? :frowning:

I know it’s stupid to ask but I will anyways

If this a laptop your talking about this does not apply

  • do you have the HDMI/DisplayPort plugged in the GPU and not the motherboard

  • do you have the latest driver of NVIDIAGeForce
    ( since you have a rtx 3060, if it actually says gtx 3060 its fake graphics card)

I’m ashamed to say I never actually realised (I read it but my mind didn’t register it) that it’s not a GTX but an RTX. :man_facepalming: But no, it’s a full on tower and the display is on the graphics cards. Also worth mentionning: All other games like Overwatch 2, Minecraft with a badass shader, Rust, Raft, Valorant, all work fine even with OBS and Streamlabs (Okay when both are open some start struggling but that’s expected) GS3 freaks out on its own even at lowest settings.

And the graphics drivers? Those could have a huge impact

The drivers are the proper ones straight from NVidia, the Game Ready one updated with GeForce Experience

I’ve got all the same issues it’s unplayable and idk how to fix it I’ve tried everything listed

A little update. Both the driver and the game had updates so I said might as well try again, and something somewhere was fixed because I can now play again! It might start freaking out soon like last time but so far it’s doing great.